(一) Route Maps
特性:
Route Maps 类似于 access lists,不同之处在于 Route Maps 可以改变 Packets/Routes 的部分属性。
用途:
Route Maps 主要用于 Redistribution 和 Policy Routing 及 BGP 的实现。
实现:
Policy Routing 发送 Packets 到 Route Maps 实现策略路由转发。
Redistribution 发送 Routes 到 Route Maps 实现路由条目的过滤。
配置说明:
Route Maps 如果没有指定 Action 及 Sequence Number 属性,默认:
Action: permit
Sequence Number: 10
且 Sequence Number 不会自动增加。
即如果在使用 Route Maps 语句时不指定 Sequence Number,则覆盖 Sequence Number 为10的 默认条目。
Route Maps Deny Action:
Redistribution: 特定路由条目不会被重分布。
Policy Routing: 特定的 Packets 不会按策略路由转发,但会梗概正常的路由表条目转发。
Case Study:Policy Routing
注:(1)Policy Routing 只影响入流量。
(2)可以使用 Standard 及 Extended ACL。
(3) 全 局配 置 ip local policy route-map sense 可 将策 略路 由应 用于 Router 本 身发 送 的 Packets.
<1> Standard ACL
interface Serial 0
ip address 172.16.5.1 255.255.255.0
ip policy route-map sense
!
access-list 1 permit 172.16.6.0 0.0.0.255
access-list 2 permit 172.16.7.0 0.0.0.255
!
route-map sense permit 10
match ip address 1
set ip next-hop 172.16.4.2
!
route-map sense permit 20
match ip address 2
set ip next-hop 172.16.4.3
<2> Extended ACL
interface Ethernet 0
ip address 172.16.1.4 255.255.255.0
ip policy route-map sense
!
access-list 105 permit tcp 172.16.1.0 0.0.0.255 eq ftp any
access-list 105 permit tcp 172.16.1.0 0.0.0.255 eq ftp-data any
access-list 106 permit tcp 172.16.1.0 0.0.0.255 eq telnet any
!
route-map sense permit 10
match ip address 105
set ip next-hop 172.16.2.1
!
route-map sense permit 20
match ip address 106
set ip next-hop 172.16.3.1
<3> Length of the Packets
interface Ethernet0
ip address 172.16.1.4 255.255.255.0
ip policy route-map sense
!
route-map sense permit 10
match length 1000 1600
set ip next-hop 172.16.2.1
!
route-map sense permit 20
match length 0 400
set ip next-hop 172.16.3.1
<4> Router's Packets
interface Ethernet0
ip address 172.16.1.4 255.255.255.0
ip policy route-map sense
!
ip local policy route-map sense
!
access-list 120 permit ip any 172.16.1.0 0.0.0.255
access-list 120 permit ospf any any
!
route-map sense permit 10
match ip address 120
!
route-map sense permit 20
match length 1000 1600
set ip next-hop 172.16.2.1
!
route-map sense permit 30
match length 0 400
set ip next-hop 172.16.3.1